DLP agent Hotfix installation fails due to SecureRepair Failed
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DLP agent Hotfix installation fails due to SecureRepair Failed

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Article ID: 215265

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Updated On:

Products

Data Loss Prevention Endpoint Suite

Issue/Introduction

When attempting to install a DLP agent hotfix using the patch method (DLP Agent installation general overview) you encounter the following errors in the MSI installer log:

MSI (s) (70:78) [11:11:21:422]: SECREPAIR: Error determining package source type
MSI (s) (70:78) [11:11:21:422]: SECUREREPAIR: SecureRepair Failed. Error code: 52447527840
Action start 11:11:21: ProcessComponents.
MSI (s) (70:78) [11:11:21:425]: Note: 1: 2265 2:  3: -2147287035 

OR

MSI (s) (5C:F0) [12:27:25:341]: SECREPAIR: Error determining package source type
MSI (s) (5C:F0) [12:27:25:341]: SECREPAIR: Cleanup the Hash Value
MSI (s) (5C:F0) [12:27:25:341]: SECUREREPAIR: SecureRepair Failed. Error code: 524FE9783E8
Action start 12:27:25: ProcessComponents.
MSI (s) (5C:F0) [12:27:25:345]: Note: 1: 2265 2:  3: -2147287035 

Environment

DLP 15.x and DLP 16.x 

Cause

The first error may be caused by having a 64-bit agent installed to the Program Files (x86) directory. Note 2265 means "Could not commit storage. System error: [3]." This is not a DLP agent issue per se, but a Windows Installer / OS environment issue.

The second error is caused by changing the name of the Agent MSI installer.  The MSI installer needs to be the same as that of the source MSI name (MSI installed initially).

Running installation inside multi-package transaction C:{file path}\AgentInstall-x64_16.0_MP2HF6.msi
Package name retrieved from configuration data: 'AgentInstall-x64_16_0.msi'

Resolution

Workaround for first error

Instead of installing the hotfix via the typical HF patch method:

  1. Uninstall the currently installed agent - Uninstall and remove the Symantec DLP Endpoint Agent
  2. Install the agent version you're trying to upgrade to - DLP Agent installation general overview

Resolution for second error

  1. Specify the msi name as "AgentInstall-x64_16_0.msi (or specific version downloaded)
  2. From an Administrative command prompt, run the following command:
    1. msiexec /i AgentInstall-x64_16_0.msi /q LOGDETAILS="Yes" /L*v %SystemDrive%\upgradeAgent.log REINSTALL=ALL REINSTALLMODE=vomus

Additional Information