search cancel

Refresh of Workflow Monitor causes JCP to become unresponsive

book

Article ID: 215175

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

In issue was found where refreshing a Workflow Monitor of a very large Workflow sporadically causes the JCP to generate a forced trace and to become unresponsive.

 

In such a situation you would find a line in the JCP log like follows:

20210305/105106.409 - 2217   U00045001 The database connection with session id '358' is no longer valid.
20210305/105106.411 - 2217   U00045014 Exception 'java.sql.SQLRecoverableException: "Closed Connection"' at 'oracle.jdbc.driver.PhysicalConnection.getAutoCommit():1828'.
20210305/105106.411 - 2217   UCUDB32 RBCK RET 0001 HSTMT: 0000000000000358 VALUE: 0000000000000000 ALL:  0.00100 DB:  0.00000 ODBC:  0.00000 UDB:  0.00000
20210305/105106.412 - 2217   U00045000 Database connection with session ID '358' was closed.
20210305/105106.413 - 2217   UCUDB32 CLST RET 0000 HSTMT: 0000000000000358 VALUE: 0000000000000000
20210305/105106.417 - 2217   U00003434 Server routine  'ErtEstimationResource$$Lambda$282/0x000000084065f440/rest-transaction' required '0' minutes and '21' seconds for processing.
20210305/105106.419 - 2217             EXIT ErtEstimationResource$$Lambda$282/0x000000084065f440 TIME: 21684ms
20210305/105106.421 - 2217   UCUDB32 RBCK RET 0001 HSTMT: 0000000000000358 VALUE: 0000000000000000 ALL:  0.00000 DB:  0.00000 ODBC:  0.00000 UDB:  0.00000
20210305/105106.422 - 2217   U00045014 Exception 'java.sql.SQLException: "Unable to rollback session 358 because the connection is already closed."' at 'com.automic.database.impl.DBConnectionImpl.rollback():241'.
20210305/105106.423 - 2217   U00003620 Routine 'com.automic.database.api.DBException' forces trace because of error.

 

Cause

The issue is caused by a 20 seconds timeout, which stops the ERT API call, if it takes longer than that. This causes the DB connection to be forcibly closed.

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Resolution

The issue has been confirmed to be a bug and will be fixed with the Automation.Engine component of

* Automation Engine V 21.0 - available

* Automation Engine V12.2.10 - available

* Automation Engine V12.3.7 - available