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ACC : Agent Does not connect to ACC through Cloud Proxy

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Article ID: 215126

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Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

We want to use ACC for agent deployment and management. 

when

introscope.agent.acc.controller.configurationServer.url=

is provided with cloud proxy details, agent does not connect to ACC.

if we provide DX gateway details along with proxy information, then only the agent connects to ACC.

 

We need the ability for the agents to connect to ACC through the cloud proxy.

 

Cause

 The problem is the URL used is without a schema (http(s)/ws(s)) - such a connection string is considered as a legacy one which is (was) used for isengard communication (isengard's default port is 5001)
 


So the ACC allows use of such a connection string, but it sets it for em-connection bundle only - it does not set it to the  acc controller bundle, because the acc controller does not communicate via isengard protocol, but  uses REST over http(s)/ws(s) . 

 

Environment

Release : SAAS

Component :

Resolution

in both scenarios enable http(s)/ws(s)  on the cloud proxy


1) Enable http(s)/ws(s) on the cloud proxy and use connection over http(s)/ws(s) - for this scenario, just change the cloud-proxy (on the first panel of package creation) and it will be set for both em-connection and acc-controller bundles.


OR


2) Enable http(s)/ws(s) on the cloud proxy and manually set the connection url to the property introscope.agent.acc.controller.configurationServer.url of the acc-controller bundle     


Note - This also explains why the acc-controller was not able to connect even the introscope.agent.acc.controller.configurationServer.url was set manually on installed agent - isengard protocol (port 5001) is not 'compatible' with the http(s)/ws(s) which the acc-controller uses.