search cancel

"Error: Microsoft PowerShell is required before installing before installing Symantec Mail Security for Microsoft Exchange" error while installing Symantec Mail Security for Microsoft Exchange

book

Article ID: 215117

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

While installing or upgrading Symantec Mail Security for Microsoft Exchange, you receive an error that PowerShell is required for installation. You already have a recent version of PowerShell installed on your system.

Cause

An older version of PowerShell is missing or has otherwise been removed from your SMSMSE system. This is causing the installer to fail when SMSMSE checks for the presence of this version. 

Resolution

Reinstall PowerShell 2.0 in order to resolve this issue. This will allow the prerequisites check to succeed and the install to complete successfully.