SIM is failing during Upgrade/Installation with error: There is no script engine for file extension .vbs
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SIM is failing during Upgrade/Installation with error: There is no script engine for file extension .vbs

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Article ID: 215111

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Updated On:

Products

IT Management Suite Installation Manager (formerly AICM)

Issue/Introduction

The customer is trying to upgrade to ITMS 8.6. During the first step of the installation process, SIM (Symantec Installation Manager) fails with the following message:

There is no script engine for file extension .vbs

Environment

ITMS 8.5, 8.6

Cause

This is a Windows issue. The proper association for .vbs file type is not set properly.

Resolution

There are different recommendations on how to fix this error message. The most common one:
The problem is caused by associating .vbs files with a program other than Microsoft Windows Based Script Host (the default). 
You can find out by searching for "Change the file type associated with a file extension" from the start menu. Make sure that .vbs files have Microsoft Windows Based Script Host set as the current default program.

OR

By re-associating the .vbs files with the following command:
cmd-->Run as Administrator --> now type the following command and press enter:

assoc .vbs=VBSFile

In this particular situation, the customer had .vbs files already associated with Microsoft Windows Based Script Host already. 

If that is the same case for you, check the following reference under HKEY_CLASSES_ROOT\.vbs and make sure it is assigned to "VBSFile".

We made the change and it worked. SIM was able to start the upgrade process without this failure.