File is currently stuck in CA Spool database due to RACF message
search cancel

File is currently stuck in CA Spool database due to RACF message

book

Article ID: 215105

calendar_today

Updated On:

Products

Spool

Issue/Introduction

User changed a RACF USER ID and since then there is a file that they are looking to release but it is stuck in CA Spool.

We got RACF to give give the proper access for file. But when I tried to release it with A command via the panel but I see the same RACF message in the log. Do we have to recycle CA SPOOL Started task?

Below are the messages I see in the log:

ICH70001I userid   LAST ACCESS AT 11:49:59 ON WEDNESDAY, MAY 12, 2021     
ICH408I USER(userid  ) GROUP(group ) NAME(name             )  308    
  CA.CASPOOL.FTP.F006084 CL(DATASET ) VOL(*BLANK)    
  DEFINE - INSUFFICIENT AUTHORITY                                         

ESF921  File   6084 on printer FTPPRT initially,      7 pages (Sock# -001)    
ESF954  File   6084 on printer FTPPRT - SAM DS Alloc failed - RC=04, Error=970
ESF954  File   6084 on printer FTPPRT - DSN=TEST.USERID.FTPPRT.F006084.T074
ESF925  File   6084 on printer FTPPRT held                                    
ESF420  PRINTER FTPPRT INACTIVE, CLASS = ALL                                                                          

 

 

Environment

Release : 14.0

Component : CA Spool

Cause

Environmental problem.

Userid in question doesn't have authorization in RACF to create the temporary dataset required by the FTP driver.

Resolution

1) Grant permission for the owner of the file to create datasets with names matching the value of the parameter DSNAME of the FTP NODE. For example:
          DRIVPRM2='DSNAME=TEST.&UID.&NOD.&FNO.&TIM',

2) Release the file that had the problem or create a new file