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CA Datacom hangs with many tasks in TASK ACTIVE status

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Article ID: 215091

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Updated On:

Products

Datacom

Issue/Introduction

CA Datacom stops processing tasks.

A COMM STATUS report shows all tasks are waiting on other tasks which are all in TASK ACTIVE status.

 

Cause

Tasks that are in TASK ACTIVE status are active tasks running in CICS.

See the documentation on COMM STATUS

TASK ACTIVE
The CICS transaction has a locked thread but is not currently waiting on a MUF request.

This means the Datacom tasks are waiting on CICS tasks to complete.

This does not indicate a problem in Datacom.

Environment

Release : 15.1

Component : CA DATACOM/DB

Resolution

Check the status of the active tasks in CICS. Use CEMT I TASK or some other CICS monitor.

Information about the CICS task Datacom is waiting on is in the ID section of the COMMS STATUS display. For example:

DB01328I - TIME   I/O  JOBNAME R-UNIT TASK CMD-DBID-TBL    SEQ STATUS          ID               TSN
DB01329I -             PCICS 99502  221 ADDIT 100ASE        TASK ACTIVE     R112D084XXX30480 0C25A76D

The ID is R112D084XXX30480 this consists of:

  • First 4 bytes is the transaction ID = R112
  • Next 4 bytes is the terminal ID = D084
  • Next 3 bytes is the operator ID = XXX
  • Next 5 bytes is the task identification number = 30480

In this case you would issue in CICS -  CEMT I TASK(30480)