Usage Manager Store is Full error
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Usage Manager Store is Full error

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Article ID: 21478

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Description:

SOI stopped processing all alerts from all connectors.
In the \SOI\tomcat\logs\sam.log or soimgr.log or soimgr-debug.log or catalyst.log, the following messages are repeated.
'Usage Manager Store is Full'


Environment

SOI 3.3, 4.0 and 4.2

Cause

The SOI\tomcat\webapps\activemq-web\activemq-data folder has a size limitation and once it reaches the activeMQ throws the error.

Resolution

1) Stop SOI service on the SOI Manager, SOIUI & on all connectors

2) Clear all files inside SOI\tomcat\webapps\activemq-web\activemq-data\ and SOI\tomcat\temp folder 

     NOTE: The location of the activeMQ files in SOI 4.2 is CA\SOI\apache-activemq\data\kahadb

3) Start only CA SAM/SOI Application & UCF Brocker and MQ service, wait until  Server application startup shows COMPLETED in sam debug page\Triage Tests

     NOTE: 

     In SOI 4.2 the activeMQ is decoupled from SOI manager. Now you don't have to stop all the services as mentioned above instead all you have to do is stop the SOI MQ service, clean the activeMQ files and start SOI MQ service.

4) Then start one connector at a time