Can't find RF Server during install or configuration step
search cancel

Can't find RF Server during install or configuration step

book

Article ID: 214769

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

CA SDM installation failed at Configuration step with error:  Can't find RF server XXX

Environment

CA Service Desk Manager 17.x
SQL Server (all applicable releases)

Cause

From SDM server login to DB is failing

StdLogs have entry as:

pdm_ver               392 ERROR        ServerStatusMonitor.  1783 Can't find RF server XXX
pdm_ver               392 EXIT         ServerStatusMonitor.   587 Slump host XXX is not defined as an RF server or is not configured and active

and install.log:

[DeployThread: Configuring CA Service Desk Manager] [ConfigureSDM] Executing remote query : sqlcmd  -S XXX -U [username] -P [PASSWORD] -i tmp_sql.sql 
[DeployThread: Configuring CA Service Desk Manager] [ConfigureSDM] Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : Named Pipes Provider: Could not open a connection to SQL Server [2]. .
[DeployThread: Configuring CA Service Desk Manager] [ConfigureSDM] Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : Login timeout expired.
[DeployThread: Configuring CA Service Desk Manager] [ConfigureSDM] Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online..

Resolution

-> We have to check below points on SDM application server:

1. Launch management studio and make sure that we can successfully login with same data given in installation window.
example: if at installation we gave DB server as :xxx
then at management studio-> use the same xxx.

Or if at DB window in installation step you have specified DB server as :xxx,1900 (1900, being new port number you used in instance name)
then at management studio also -> use the same xxx,1900

2. From command prompt check this command:

sqlcmd -S [SQLSERVER] -U [username] -P [password]

Also, for named instances and ports:

sqlcmd -S "[SQLSERVER]\[INSTANCE],1234" -U [username] -P [password]

update SQL server name, instance, port, username and password in above syntax with your details.

If this step fails, this indicates that the given SDM Server will not be able to talk to the given SQL Server and the DB Admin or Network Admin should be involved to check the SQL Server and network setup.   Another diagnostic to try is to deliberately give incorrect information to compare against a parameter set that should work.

3. From SQL server configuration manager -> make sure named pipes are enabled and correct port number is updated.

Additional Information

Other causes of the given error include: