No ADA metrics in APM (APM Connector)
search cancel

No ADA metrics in APM (APM Connector)

book

Article ID: 214721

calendar_today

Updated On:

Products

CA Application Delivery Analysis (NetQoS / ADA)

Issue/Introduction

We do not see any metrics in APM from ADA. We have the ADA connector installed.

Environment

Release : 11.1

Component : NETQOS INTEGRATED POLLER

Cause

If ADA is processing slowly, > 5 minutes to process a datafile, the APM connector will reject the datafiles as stale

Resolution

Here are few things you can do:

1) Increase the RAM and CPU power on the ADA console

2) Delete the inactive, system generated applications from the database:

  • Open a command prompt with admin priviledges
  • mysql super
  • delete from applications where inactive=1 and UserModified='N';

3) Modify you subnets configuration to encompass a smaller subset of your network (only the most important applications/servers). This will lower the amount of data coming into the console and increase the performance. If ADA is able to process the datafiles quicker (within 5 minutes), it will ensure that the APM connector works properly.

The bottom line is that ADA is being sent too much data. To ensure performance over the long term, you will need to decrease the total amount OR split the data between 2 or more ADA environments.