Unable to see "License Category" dropdown in agent definition
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Unable to see "License Category" dropdown in agent definition

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Article ID: 214697

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When attempting to resolve error: U00034036 There is no valid license for Agent 'AGENT_NAME' (license class '9', license category 'NON Production', platform 'EX.OS.UNX').

by updating the license category for the agent(s) seeing the error, found that the "License Category" dropdown does not exist.  

Automation Engine components are on 12.2.1 or lower, AWI is 12.2.2 or higher

Environment

Release : 12.2

Component : AUTOMATION ENGINE

Cause

In 12.2.2, the technical license requirement was removed from Automic Automation.  The 12.2.2 AWI no longer shows a license category.

As a workaround, the Java UI can be used, but the only supported configuration is to have the Automation Engine and AWI on the same version and service pack.

Resolution

The Automation Engine components and AWI should be on the same service pack.  Downgrading the AWI to 12.2.0 or 12.2.1 will resolve this issue.