EEM Error Failed to update user directory details, when attempting to update LDAP bind credentials in EEM
search cancel

EEM Error Failed to update user directory details, when attempting to update LDAP bind credentials in EEM

book

Article ID: 214696

calendar_today

Updated On:

Products

CA Workload Automation AE

Issue/Introduction

When attempting to update LDAP bind credentials in EEM, below error shows up and it does not seem to update the credentials.

Note: This only seems to be an issue with a fresh install of EEM 12.6 CR02  or after upgrading to EEM 12.6 CR02

 

Environment

Release : 12.6.0.2  (12.6 CR02)

Component : WORKLOAD CONTROL CENTER

Cause

Assuming the details are all correct, Connection Retry time interval keeps getting reset to 0  and we need a value higher than 0, that's why the error.

 

This is a new field in the advanced configuration for LDAP has been added:

 

EEM's  spindle.log  shows below error:

 WARN 2021-05-07 16:02:23,183 [0x2b2e90200700] [eiam.ui.spindle] LDAP connection rebind time interval can't be zero

 

Resolution

Before clicking on Save make sure the Connection Retry time interval is set to a value higher than zero and then click Save.

This value keeps resetting to 0  every time you load the LDAP properties screen.  So ensure it is higher than zero and then save.

Additional Information

This issue is also resolved in EEM release 12.6.3.0 and above

Attachments