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OAuth 2.0 Missing When Configuring Mailbox

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Article ID: 214681

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Customer does not see OAuth 2.0 as an option when configuring a mailbox in SDM

Cause

The detail_mailbox.htmpl file is being overridden by a version in site/mods.

The given RU update that introduced OAuth authentication was not installed successfully.

Environment

Release : 17.3

Component : Svc Desk Email

Resolution

Examine the site/mods directory and see if there is an older version of the mailbox htmpl file present, ie:

Directory of C:\PROGRA~2\CA\SERVIC~1\site\mods\www\htmpl\web\analyst\Admin
03/20/2020  08:47 PM             7,320 detail_mailbox.htmpl

Directory of C:\PROGRA~2\CA\SERVIC~1\site\mods\www\htmpl\web\analyst\Admin\tagged
03/20/2020  08:47 PM             8,307 detail_mailbox.htmpl

These files are older versions that would override the versions that were introduced in the 17.3 RU4 update that introduces OAuth functionality.  It is important to note that the ability to select a given security level is handled directly in the detail_mailbox.htmpl code.  There is actual scripting in the detail_mailbox.htmpl code that will place the appropriate integer value to denote the security setting in the usp_mailbox table's security_lvl field.  

In a baseline version of the detail_mailbox.htmpl form in the NX_ROOT\bopcfg\www\htmpl\web\analyst, there will be a line that reads as follows:

msgtext("Clear_Text"),"0","APOP","1","NTLM","2","MD5","3","OAUTH 2.0","4");

For the scenario where the RU update may not have completed successfully, please review KB article 214337 under "Additional Information"

Additional Information

Invalid object name usp_mailbox_oauth error
https://knowledge.broadcom.com/external/article?articleId=214337

Security value reference definitions when creating mailbox
https://knowledge.broadcom.com/external/article?articleId=215296