Missing items from VNA Viptela Inventory in DX NetOps Performance Management
search cancel

Missing items from VNA Viptela Inventory in DX NetOps Performance Management

book

Article ID: 214577

calendar_today

Updated On:

Products

CA Virtual Network Assurance DX NetOps

Issue/Introduction

Switches are missing from inventory - can't tell which domain is missing them. I installed VNA 20.2.10. I added 3 domains and configured 3 engines for them. But only one added any switches. I know there should be more. Is there a way to look through the inventory and tell which domains don't have any switches?

Only see items from one Viptela domain where there are three domains configured.

Missing Switches from Virtual Network Assurance (VNA) Inventory when integrated with Cisco Viptela.

Environment

All supported Virtual Network Assurance releases

Cause

OutOfMemory errors seen in the server.log and oc.log files. In the server.log we see this show up before everything starts failing.

2021-05-06 21:16:09,624 WARN  [org.apache.activemq.artemis.core.client] (Thread-30 (ActiveMQ-client-global-threads)) AMQ212037: Connection failure to invm:0 has been detected: AMQ219014: Timed out after waiting 30,000 ms for response when sending packet 71 [code=CONNECTION_TIMEDOUT]
2021-05-06 21:16:09,628 WARNING [org.glassfish.grizzly.filterchain.DefaultFilterChain] (Grizzly(2)) GRIZZLY0013: Exception during FilterChain execution: java.lang.OutOfMemoryError: Java heap space
...
2021-05-06 21:16:09,629 WARN  [org.apache.activemq.artemis.core.client] (Thread-29 (ActiveMQ-client-global-threads)) AMQ212037: Connection failure to invm:0 has been detected: AMQ219014: Timed out after waiting 30,000 ms for response when sending packet 71 [code=CONNECTION_TIMEDOUT]
2021-05-06 21:16:13,934 ERROR [io.undertow.request] (default task-1) UT005023: Exception handling request to /vna/rest/v1/admin/ping: org.jboss.resteasy.spi.UnhandledException: java.lang.OutOfMemoryError: Java heap space
...
Caused by: java.lang.OutOfMemoryError: Java heap space

The error observed in the oc.log file is:

2021-05-06 21:16:09,629 ERROR (EE-ManagedThreadFactory-default-Thread-2) ACI_57536497-e666-4d81-b7f8-d03a95b73d14=Inventory Poll [OC_ACQUISITION] TimProcessFunction 182  Failed to invoke plugin AciEndPointPaginate from AciEndPointPaginate Acquisition Endpoints: java.lang.reflect.InvocationTargetException
...
Caused by: java.lang.OutOfMemoryError: Java heap space

Resolution

Reconfigure the VNA_MAX_MEM value in the VNA_HOME/wildfly/bin/standalone.conf file.

  • In VNA_HOME/wildfly/bin/standalone.conf file, change VNA_MAX_MEM. By default it is 4gb.
  • After making the change restart the Wildfly service using the commands:
    • Stop wildfly:
      • RH6.x: service wildfly stop
      • RH7.x: systemctl stop wildfly
    • Start wildfly:
      • RH6.x: service wildfly start
      • RH7.x: systemctl start wildfly

The memory issues should be resolved and the complete Inventory should now be seen.