Error when logging onto upgraded web client and using Chrome browser
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Error when logging onto upgraded web client and using Chrome browser

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Article ID: 214517

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Updated On:

Products

Vantage Storage Resource Manager

Issue/Introduction

When upgrading the Vantage Web Client from 14.0.06 to 14.0.07 (and additionally, from 14.1.3 to 14.1.4 StoragePoint) and logging on for the first time after the upgrade, the logon screen shows no database is available from the pulldown menu.  When attempting to login using the 'APP' userid, it also fails.  The following messages are produced in the Vantage Web Client STC: 

 

INFO: vanrpcServlet: ERROR: The serialization policy file '/vantageGMI/03E57FBA39B5FA8900A2B122D6FC0233.gwt.rpc' was not found; did
you forget to include it in this deployment?                                   
May 06, 2021 11:05:50 AM org.apache.catalina.core.ApplicationContext log       
INFO: vanrpcServlet: WARNING: Failed to get the SerializationPolicy '03E57FBA39B5FA8900A2B122D6FC0233' for module 'http://167.113.75
.40:8080/VantageGMI/vantageGMI/'; a legacy, 1.3.3 compatible, serialization policy will be used.  You may experience SerializationEx
ceptions as a result.                                                          
May 06, 2021 11:05:50 AM org.apache.catalina.core.ApplicationContext log       
SEVERE: Exception while dispatching incoming RPC call  

 

Environment

Release : 14.0

Component : CA Vantage Storage Resource Manager

Cause

The browser cache or mainframe cache contains data which is interfering with the login process. 

Resolution

Steps to resolve this problem:

1) Clear the browser cache and retry logging in again. 

2) If clearing the browser cache does not resolve this problem, then on the mainframe stop the Vantage Client task and navigate to the folder:

yourUSSpath/runtime/apache-tomcat-x.x.xx/work/Catalina/localhost/

and delete the folder 'VantageGMI', such as with the OMVS command:   "rm -R VantageGMI"  and then clear the browser cache again, and then recycle the Vantage task and then try logging into the Web Client. 

3) If step #2 does not resolve this problem, then on the mainframe stop the Vantage Client task and navigate to the folder:

yourUSSpath/runtime/apache-tomcat-x.x.xx/webapps/

and delete the folder 'VantageGMI', such as with the OMVS command:   "rm -R VantageGMI"  and then clear the browser cache again, and then recycle the Vantage task and then try logging into the Web Client

4) If these steps fail to resolve the problem, you may try to use other browsers, such as Firefox.

5) The Windows PC may be rebooted, which has been found to resolve this problem as well (in migration to StoragePoint 14.1.4)

NOTE: Do not delete the VantageGMI.war file.

 

 

Additional Information

The Microsoft IE browser does not appear to have this problem, but should it have similar problems, the above steps should be followed..