Protection Engine fails to start: Failed to initialize IPC Channel
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Protection Engine fails to start: Failed to initialize IPC Channel

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Article ID: 214501

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS Protection for SharePoint Servers

Issue/Introduction

Symantec Protection Engine (SPE) fails to start. The SymantecProtectionEngineAbortLog.txt shows the following error:

2021/05/06-17:18:34 1400 Failed to initialize IPC Channel.
2021/05/06-17:18:34 0 Symantec Protection Engine is shutting down; logs may contain more information.

Cause

By default, the IPC server listens on port 9002 while the IPC agent listens on 9001. If these ports are not available, SPE will fail to start with the error above.

Resolution

Configure SPE's IPC server and agent to listen on unused ports:

  1. Find two ports on the server not currently in use. You can use a command such as 'netstat' to see what ports are currently in use.
  2. Use the following two commands to configure the IPC settings with the new ports:
    • .\XMLModifier.exe -s /configuration/IPCChannelSettings/ServerPort/@value <port number> configuration.xml
    • .\XMLModifier.exe -s /configuration/IPCChannelSettings/AgentPort/@value <port number> configuration.xml
  3. Start SPE.

If this does not resolve the issue, contact support.

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