Resetting the Licensing for TDM Portal
search cancel

Resetting the Licensing for TDM Portal

book

Article ID: 214483

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We have installed TDM in our production environment and started using it.
We have already created Projects and Data Models that we cannot afford to lose.
During the installation, we accidentally chose PLA licensing by mistake.
How can we change this back to standard licensing?

 

Environment

 

All support TDM Web Portal releases.

With GTREP Repository database hosted on SQL Server

Cause

 

Incorrect options are chosen during installation

 

Resolution

In order to reset the licensing for TDM Portal, you would need to do the following:

  1. Connect to your SQL Server that hosts the GTREP database with a user with full rights

  2. Run the following SQL query:
    delete from  gtrep_system_settings where ss_name ='LICENSING_MODEL'

  3. If you are logged into the Portal, logout and close the browser
  4. Open a new browser and log back into the portal with the administrator username and password.

  5. You should then get the activation screen to come up, which you can walk through again.

  6. Make sure you enter your License key in the enterprise site ID field as per the documentation below:
    Refer to section "Activate Test Data Manager" in the documentation of the TDM release you are running.