SOI - ssa_IFW.log - Login failed for user '<db user>'
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SOI - ssa_IFW.log - Login failed for user '<db user>'

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Article ID: 214481

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

 

After upgrading SOI to 4.2 CU1 there are a lot of the following entries in the ssa_IFW.log:


Exception:Login failed for user 'sa'
 
 
The user "sa" is the database user used by SOI.

It's not possible to find the file, where the password for the user could be incorrect. 
 
Where could this be coming from?

Environment

Release : 4.2

Component : SOI ALERT MANAGEMENT

Cause

 
 
 
 
This related to an event policy that would make a database update through enrichment.
 
The explanation is that the policy was active in the past but it wasn't properly un-deployed from Event Policy editor, hence this policy is still active for Event management engine.
 
In general, to un-deploy any policy, it has to be properly undeployed from Event Policy GUI, then the .xml file in \SOI\resources\core\catalogpolicy\extensions folder will be updated.
 
However, the policy definition file .policy still available in \SOI\resources\eventmanagement\policies folder, but these files will not be loaded when we restart IFW / Event management.
 
So, look at  \SOI\resources\core\catalogpolicy\extensions folder again and look at all .xml files with size > 1 KB and then delete or move if they are not needed

Resolution

 
 
 

Enable debug logging to find more details about the event policy that is causing the error

SOI\resources\log4j_IFW.xml 

    <logger name="com.ca.sam.ifw" additivity="false">
        <level value="DEBUG" />
        <appender-ref ref="IFW" />
    </logger>

Additional Information

 
This is a scenario with the managers in cluster using shared drive for configuration.
 
The policy was on the local drive of the cluster node (in \Catalogpolicy\extensions)