Agent does not start with expected values of open_file_max
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Agent does not start with expected values of open_file_max

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Article ID: 214444

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

After restarting the server, a particular application run by a Unix Agent throws the following error message:

“Hard limit on open files is too low : 32768 (should be at least 65535)”

The reason seems clear: the default value of open_file_max in the Agent's ini-file is 32768.

 

However, if open_file_max is set to 0, indicating that it should be set the open_file_max to the system's nofile limit, the value is actually set to 4096 instead of 65535 (ulimit -n 65535)

Environment

Release : V 21.0.x and V 24.x

Component: AUTOMATION ENGINE

Cause

It appears that there is system default for the root user's nofile limit

>systemctl show -p DefaultLimitNOFILE

DefaultLimitNOFILE=4096


While the setting in filelimit.conf is higher upon reboot of the server the default values is used in init.d

/etc/systemd/system/oneAutomation.d/filelimit.conf:

[Service]

LimitNOFILE=65535

Resolution

Setting open_file_max=65536 solves the issue for the specific application, but works only after restarting the Agent after the automatic start after reboot.

When the Service Manager is started by root in init.d the lower default limit is assigned.

 

Possible workaround:

Since the Agent is started with root privileges because of the setUID (-rwsr-sr-x), it should work to start the service manager as 'uc4' or 'automic' in init.dand keep open_file_max=0