Process does not start if only given 'Process Start' instance access right
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Process does not start if only given 'Process Start' instance access right

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Article ID: 214424

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Processes are not initiating if user only has Process Start access.

Steps to Reproduce:

  1. Create a simple process called P1 on Object “Project”, with start step the goes to Finish
  2. Give the Instance Rights below to User1 for process P1
    • Process - Start
    • Project - Edit
    • Project - View
  3. Copy of P1 to a process called P2,
  4. Give Instance Rights below to the User2 for process P2
    • Process - Manage
    • Process - Start
    • Project - Edit
    • Project - View
  5. Make both processes available in Project Actions Menu
  6. Log in with as User1 and select P1 from the Action Menu
  7. Log in with as User2 and select P2 from the Action Menu

Expected Result: Both Processes initiated because the 'Process - Start' Instance Right should be sufficient.

Actual Result: Only process P2 is initiated because User2 has the 'Process - Start' and 'Process - Manage' Instance Access Rights

Environment

Release : 15.9.1

Component : CA PPM BUSINESS PROCESS MANAGEMENT

Cause

This issue is caused by DE60512.

Resolution

This issue is fixed in Clarity 15.9.1 patch #1.

Workaround: Use the 'Process - Manage' Instance Access Right.

Additional Information

Please also see: 

Process Start Instance Right is not checked properly resulting in the user being unable to start a process if they just have that instance right