Unable to auto-connect to DB
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Unable to auto-connect to DB

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Article ID: 214355

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Customer have patch implemented on Oracle DB and during this activity primary DB is not available. Once DB gets online, customer see exception in IDM where it is unable to connect. How to make IDM auto-connection when DB back up.

 

 

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

WebSphere 8.5.5

Cause

This is due to Database disconnect with applications during patch maintenance.

Resolution

1. Login to WAS console.
2. Navigate to Data sources>Oracle JDBC Driver (assume Oracle DB) Datasource>WebSphere Application Server data source properties
3. Enable ‘Validate new connections’ and enter values for ‘Number of retries’ and ‘Retry interval’ as shown in screenshot.