search cancel

Operator console upgrade fails for secure version of UIM robot

book

Article ID: 214308

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

On running the Operator console installer upgrade from 20.3.2 to 20.3.3 (using secure versions of hub/robot) below error is observed 

It fails during the distributing packages phase 

Environment

Release : 20.3.2/ 20.3.3

Component : UIM - ROBOT

robot /hub 9.33 secure

automated_deployment_engine 20.31

Resolution

Below error is observed in ADE logs

The OC installer uses the automated_deployment_engine probe to deploy probes during installation

Please add/ increase number of threads for the below parameters in OC robot.cfg 

proxy_wq_inbound_max_threads = 5
proxy_wq_outbound_max_threads = 5

Restart OC robot

Restart the OC installation again on Primary hub pointing to the secure OC robot 

Additional Information

Deployment of probes to secure robots via automated_deployment_engine fails

 

Handling Multiple Requests

Attachments