MQ services details not showing in Virtual Service Catalog console
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MQ services details not showing in Virtual Service Catalog console

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Article ID: 214255

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Updated On:

Products

Service Virtualization

Issue/Introduction

Have web services and MQ services virtualized.

The Virtual Service catalog (VSC) is not showing the configuration details of MQ Services from one environment whereas the same services show from in another environment.

 

Environment

All supported DevTest releases.

Cause

- There were 2 different Registries UAT & QA.

- MQ Services in UAT were appearing with VS Specifics details in VSC but not the VS from QA

- Diagnosed the problem using V2 APIs that are actually invoked by VSC

http://QARegistryHostmane:1505/lisa-virtualize-invoke/api/v2/vses/dP9DWRdyeXgRLcvPgRRD1SsQAUR1wKiDW59V9

http://QARegistryHostmane:1505/lisa-virtualize-invoke/api/v2/vses/dP9DWRdyeXgRLcvPgRRD1SsQAUR1wKiDW59V9/services

http://QARegistryHostmane:1505/lisa-virtualize-invoke/api/v2/vses/dP9DWRdyeXgRLcvPgRRD1SsQAUR1wKiDW59V9/services/g_X06bUmxVVL/specifics

Upon checking using the REST API calls, it was noticed that there was an exception returned instead of the specifics data of the VS in registry.log file. 

"Type com.ibm.mq.MQMessage not present"

This exception means that the class com.ibm.mq.MQMessage couldn't not be found. Upon checking the DEVTEST_HOME/lib/shared folder, it was found that "com.ibm.mq.allclient-9.1.2.0.jar" was present in UAT but not in QA.

Resolution

Placed the "com.ibm.mq.allclient-9.1.2.0.jar" inn the  DEVTEST_HOME/lib/shared folder on QA server and restarted Registry service.

After this change was then able to see the MQ details on the VSC for the virtual services running in the QA environment.