ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

DX Gateway fails and stops processing Alarms

book

Article ID: 214254

calendar_today

Updated On:

Products

DX SaaS

Issue/Introduction

Noticed the DX Gateway has stopped processing alarms for one of the Tenants. Need to understand why it fails and stops processing alarms. The only resolution is to recycle the DX OnPrem Gateway service, it then starts processing again.

Cause

From DX Gateway Log Analysis:

"Issue seems to be happening because of the following OOM for tenant-dxgateway instance. 

 

2021-05-18 16:03:33 [task-scheduler-9] ERROR o.s.i.h.LoggingHandler -
                java.lang.OutOfMemoryError: Java heap space

 

Environment

Release : SAAS

Component :

Resolution

Add more resources / heap to the server.