CA7 Jobs submitting with JCL error but running successfully
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CA7 Jobs submitting with JCL error but running successfully

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Article ID: 214200

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Updated On:

Products

CA 7 Workload Automation

Issue/Introduction

We have an issue where 2 long running jobs are being submitted to CA7 with a submit time of 05:00. When the submit time is reached - the currently active jobs are purged and the new jobs submitted which then run till 05:00 the next morning when they are purged and the following days jobs submitted. 


The 2 jobs  are submitted and immediately issue the following error msgs and have a status of R-JCLERR in CA7 , but run without error in z/OS   

SMF0-18 JOB JOBA (3511) HAS JCL ERROR
SMF0-18 JOB JOBB (3512) HAS JCL ERROR

This issue started occurring last week - there have not been any changes to the JCL and there don't appear to be any other errors (that we can see) in either of the job output or the CA7 logs.

Environment

Release : 12.1

Component : CA-7

Cause

The error occurred because the new days jobs were Submitted to the Request queue before the currently active jobs were cancelled in Jes

Resolution

The new days jobs were held after they came onto the queue and were released after the currently active jobs were stopped in Jes.