After applying license, error on agents: U00034036 no valid license
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After applying license, error on agents: U00034036 no valid license

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Article ID: 214094

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

After applying a license file, receiving error in one environment:

U00034036 There is no valid license for Agent '[AGENT NAME]' (license class '9', license category'NON Production', platform 'EX.OS.UNX').

The license used to include a NON Production category and does not any longer.

Environment

Release : 12.2

Component : AUTOMATION ENGINE

Cause

This is caused either by having the incorrect license class (in the case above, a 9 as opposed to a V).

The license section in client 0 will show which license class can be used looking in the "Class" column and which Category this should be based on what is the "Category" column:

This same information should have been sent with the license when it was first received in a .pdf file.  It can also be found in the UC_Lic table of the database (WARNING!  Any attempt to update this table will result in a system outage!)  More information on the UC_Lic table can be found here: https://docs.automic.com/documentation/webhelp/english/AA/12.3/AE/12.3/DB%20Schema/db/_structure/HTML/UC_LIC.html

Looking at the message U00034036 There is no valid license for Agent '[AGENT NAME]' (license class '9', license category'NON Production', platform 'EX.OS.UNX').

it shows that the agent is currently attempting to use license class 9 and category "NON Production".  Looking at the license section of the administration perspective above, we can see that the only category available for a license class 9 of platform "EX.OS.UNX" is "Production".

Resolution

To resolve this, right-click on the agent object in Client 0 and choose Open.  Go to the "Agent" tab and update the License Category dropdown to an available license category