Getting multiple Reboot prompts even when a deferred time has been selected
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Getting multiple Reboot prompts even when a deferred time has been selected

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Article ID: 214011

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Updated On:

Products

IT Management Suite Patch Management Solution Software Management Solution

Issue/Introduction

Scenario:
1. The customer has set up his reboot policy to restart automatically after 8hrs if no response is provided (either to restart now or postpone) but the end-user can defer it up to 1 day as the max option to select. 
He also set it to remind the end-user every 8 hrs if they decided to postpone.

2. The client machine gets the patch policy and it requires a reboot, which triggers the agent UI and the customer selected to postpone/remind in 4hrs. 

3. Then in approx. 1 hour later he got again the agent UI asking him about a restart or postpone schedule.
(even when he selected to postpone/remind for a later time, in this case 4 hrs later from the first time that he got the initial window)

Questions:
1. Why is the customer getting prompted to select a "restart" time before the previously selected "postpone" time is over?

2. If a customer selected to defer the machine restart and then another patch comes alone and that one also requires a restart, our agent will ignore the previous selection and prompt again for the end-user to select a new time to defer or select to restart?

Environment

ITMS 8.1, 8.5, 8.6

Cause

Working as designed. Patch plug-in issued two reboot requests so two UI notifications were shown. It does not matter that the user postponed the first one, the second request came and the notification's list contains more entries telling that more updates have been installed and the reboot is required.

Resolution

For the purpose of this article, we will use as an example actual agent log entries to try to explain the restart request flow.

As you can see in the screenshot above, one restart request was triggered at 11:53:28am and the second one at 1:08:43pm.

 

In logs there are 2 UI notifications

"4/26/20211:08:43 PM","Notify user in session 1 about power action '0x0001B001: reboot, force, notify, deferral, maintenance'","PowerAction","AeXNSAgent.exe","9192","8212"

         "4/26/2021 1:08:43 PM","Registering power action '0x0001B001: reboot, force, notify, deferral, maintenance', notification time: 480, deferral limit: 1441, deferral UI limit: 481","PowerAction","AeXNSAgent.exe","9192","8824"

"4/26/202111:53:28 AM","Notify user in session 1 about power action '0x0001B001: reboot, force, notify, deferral, maintenance'","PowerAction","AeXNSAgent.exe","9192","8212"

Both notifications showed after the Patch Plugin finished installation of updates (at end of the Patch Cycle). Patch cycle was started because of the agent received new policies for installation. For example:

"4/26/2021 12:37:42 PM","Policy {ea4b50ad-8816-4a8d-8915-d298bac801aa} has been added","PatchMgmtSoftwareUpdate","PatchMgmtAgents.dll","9192","8824"

"4/26/2021 11:35:55 AM","Policy {e8a0245e-a584-4847-a994-4203db9e1f98} has been added","PatchMgmtSoftwareUpdate","PatchMgmtAgents.dll","9192","8824" 

You should be able to find in the agent log the names for those updates that triggered the restart notification and the policy or policies that are part of, for example:

InstallSoftwareUpdate() Run Advertisement 'AcroRdrDCUpd2100120145.msp for Desktop Patches April 2021' {3A077701-8005-4FC5-8242-F18344EB344A} for update 'AcroRdrDCUpd2100120145.msp' {E8A0245E-A584-4847-A994-4203DB9E1F98}
-----------------------------------------------------------------------------------------------------

InstallSoftwareUpdate() Run Advertisement 'VC_redist_14.28.29914.0_x86.exe for Desktop Patches April 2021' {8B7D826D-7158-443B-8453-A97AF3F9A055} for update 'VC_redist_14.28.29914.0_x86.exe' {EA4B50AD-8816-4A8D-8915-D298BAC801AA}
-----------------------------------------------------------------------------------------------------

In general behavior with notification looks like this:

1) agent received a policy (-ies)

2) patch plugin start Patch Cycle to install the policy

3) agent show UI notification in the end of Patch Cycle (after state Applying updates)  if reboot is required. User may start reboot immediately or delay it for some time. Next notification for is shown after specified time (see in logs for notification time: 480 - time in minutes).

In the agent logs, you should see the initial UI notifications which appeared immediately after Patch cycle, not the next UI notifications (which appeared after the selection delay of a reboot)

In general, the reboot notification uses a single schedule. Different reboot requests are "combined" into the single one. The rule is the next reboot request cannot be less strict than the previous, i.e. if "force" is specified for the first request then "force" mark will remain after the second request, the second reboot request cannot increase the deferral time, it can only decrease it, etc.