Why do we see "No event format file exists" when we check the cleared alarms history tab for historical alarms from UIM?
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Why do we see "No event format file exists" when we check the cleared alarms history tab for historical alarms from UIM?

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Article ID: 213879

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Updated On:

Products

CA Spectrum

Issue/Introduction

We have noticed that when Spectrum and UIM are integrated, that if an alarm is raised in UIM for monitoring for a process probe and this condition is violated an alarm is raised in Spectrum.
However when the alarm in UIM is cleared and the alarm is cleared in Spectrum, when checking the Cleared Alarm History, you will see an event stating "An event has occurred for model " of type " for which no event format file exists.
This makes it hard for the Spectrum Operator to reconcile the previous UIM alarms as they are not shown correctly in the Spectrum Cleared Alarm history.

Environment

Release : 20.2

Component : Spectrum with UIM Integration

Cause

The spectrum gateway generates the event via RESTful. Then the event condition will assert the alarm.

But the spectrum gateway does not generate the event to clear the alarm via RESTful. It simply send the alarm delete payload with the global alarm ID.

Resolution

This is currently Functioning as Designed (FAD) and an Enhancement Request has been raised for this to be changed.

Additional Information

If you would like to vote up the Enhancement Request it is available here:

 

https://community.broadcom.com/participate/ideation-home/viewidea?IdeationKey=a8db0089-51ec-4b4a-a015-4a532e131b82