ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Mixed PAM environment

book

Article ID: 213793

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We have 7 PAM servers in one productive environment, part of the same domain. 5 of them are in one cluster which is used by the endusers and 2 of them are in another cluster, which is used for testing.

We upgraded the TEST pam servers from 3.4. to 3.4.3 and now the PAM client is asking for an upgrade from 3.4.0 to 3.4.3.

If we accept this upgrade, I would expect that afterward the connection toward the 5 PAM server with version 3.4 and towards the 2 TEST PAM servers with version 3.4.3 to work as well from the PAM client.

Could you please confirm?

 

Environment

Release : 3.4

Component : CA LDAP Server

Resolution

The PAM client will upgrade and downgrade itself on connection to maintain the same build as the appliance its connecting to. This is normal behavior. you can disable that but we do not suggest that as it adds another possible variable in the behavior. Accept the upgrade and then it will downgrade itself when he connects back to to production