Data Collect reinstall using export DCM_ID creates invalid entry in com.ca.im.dm.core.collector.cfg
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Data Collect reinstall using export DCM_ID creates invalid entry in com.ca.im.dm.core.collector.cfg

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Article ID: 213703

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

When reinstalling Data Collector reusing the DCM_ID from the previously installed Data Collector a bad value for the collector-manager-id value is written to the com.ca.im.dm.core.collector.cfg file.

The correct steps are followed to reinstall the Data Collector on the same host it was installed on previously.

  1. Find the existing DCM_ID using <DA_HOST>:8581/rest/dcms
  2. Run the following to set the DCM_ID variable in the shell:
  3. export DCM_ID=<DC_HostName>:<ID>
  4. Run the install.bin for the DC in -i console mode.

After install the services fail to remain running. Examining the install it's found that the wrong value is set for the collector-manager-id in the com.ca.im.dm.core.collector.cfg file.

This value should show value of:

<DC_HostName>:<ID>

Instead it shows the following. Note the errant slash mark that doesn't belong after the host name but before the colon.

<DC_HostName>\:<ID>

Environment

Reported against DX NetOps Performance Management release r20.2.7.

Unable to be reproduced on Broadcom Support and Engineering labs using both r20.2.7 and the latest current release at the time of testing, r20.2.9.

Cause

Root cause is unknown at this time. Issue was seen in customer environment but not reproducible in Broadcom Support or Engineering labs. Customer was unable to attempt further reproduction on existing systems post upgrade.

Resolution

Removing the errant slash mark, saving the file changes and restarting the services resolves the issue.

Additional Information

If you see this issue, and are able to readily reproduce it allowing for additional debug logging, please open a new support case referencing this Knowledge Base Article for further assistance.

  1. One recommendation is to run "echo $DCM_ID" after setting the variable in the shell with the export command.
    1. Run it after each step after the export command is run.
    2. Run it again just before running the install.bin file.
    3. Monitor output to see if the errant slash is introduced by the system at any point.
  2. No other known debug exists for the DC installer via install.bin file. Adding new options to debug a problem like this would require engineering provided installer changes.