Evaluate could not get dev context (two parallel requests) in Risk Authentication
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Evaluate could not get dev context (two parallel requests) in Risk Authentication

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Article ID: 213632

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Updated On:

Products

CA Advanced Authentication CA Advanced Authentication - Risk Authentication (RiskMinder / RiskFort) CA Risk Authentication

Issue/Introduction

While running performance Test  We are keep on seeing following error on Advance Auth.

Fri Apr 23 15:51:48.251 2021 INFO:    pid 3044 tid 8288: 2: 1:272642: UDS Log : Successfully retrieved the user [user] for organization [ORGNAME]
Fri Apr 23 15:51:48.266 2021 INFO:    pid 3044 tid 5376: 8: 1:272641: ARRFDbOperations::getDeviceContext:deviceLockedTimeDiff - 120,timeDiffCalculated - 0 
Fri Apr 23 15:51:48.266 2021 INFO:    pid 3044 tid 8288: 8: 1:272642: ARRFDbOperations::getDeviceContext:deviceLockedTimeDiff - 120,timeDiffCalculated - 0 
Fri Apr 23 15:51:48.266 2021 WARNING: pid 3044 tid 8288: 8: 1:272642: Error in ArRFExtRuleSetEval::evaluate Could not get dev context (two parallel requests)
Fri Apr 23 15:51:48.266 2021 INFO:    pid 3044 tid 8288: 8: 1:272642: Response[7664] Reason[8123] Error String [RuleSet Evaluation failed]
Fri Apr 23 15:51:48.266 2021 LOW:     pid 3044 tid 8288: 2: 1:272642: Response sent - evaluateRisk

Environment

Release : 9.0

Component : RiskMinder(Arcot RiskFort)

Risk Authentication

Cause

RFI (Request For Information)

Resolution

Please follow the below suggestions to address this issue.

1. If you are using single user or less numbers of users for the test, the error will be very prevalent in the logs so create at least a 1000 users so Risk server receives unique user requests and not from same user again which causes this issue.

2. Run the below queries against the DB

update arrfconfiguration set value=5 where name='USERLOCKEDTIMEDIFF' and category='GLOBAL';

update arrfconfiguration set value=5 where name='DEVICELOCKEDTIMEDIFF' and category='GLOBAL';

commit;

3. There has been enhancements in the product so if you are version 9.0 or lower then upgrading to 9.1 or later and following the above suggestions will resolve the issue.

 

Additional Information

None.