ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

How do I upgrade CAMM's Apache Tomcat?

book

Article ID: 213579

calendar_today

Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration CA Mediation Manager

Issue/Introduction

CAMM Apache Tomcat 8.5.51 has some vulnerabilities that are resolved in Apache Tomcat 8.5.56, how do I upgrade to 8.5.56+?

How do I upgrade CAMM's Apache Tomcat?

CA Mediation Manager

Mediation Manager

Environment

Release: All Supported Releases

Component: Mediation Manager

Resolution

You cannot upgrade Apache Tomcat individually, it is an embedded component and as such can only be upgraded by upgrading CAMM as a whole.  For this specific version use case, CAMM 20.2.8.58 contains Apache Tomcat 8.5.58 which addresses the concern

# ./version.sh
Using CATALINA_BASE:   /opt/CA/CAMM/WEBCAMM
Using CATALINA_HOME:   /opt/CA/CAMM/WEBCAMM
Using CATALINA_TMPDIR: /opt/CA/CAMM/WEBCAMM/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /opt/CA/CAMM/WEBCAMM/bin/bootstrap.jar:/opt/CA/CAMM/WEBCAMM/bin/tomcat-juli.jar
Using CATALINA_OPTS:
Server version: Apache Tomcat/8.5.58
Server built:   Sep 10 2020 21:45:33 UTC
Server number:  8.5.58.0
OS Name:        Linux
OS Version:     3.10.0-957.12.2.el7.x86_64
Architecture:   amd64