Processes stuck in Aborting (DE60158)
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Processes stuck in Aborting (DE60158)

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Article ID: 213284

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Processes get into an aborting state and does not progress any further after cancelling a running process

STEPS TO REPRODUCE: 

1. Create an sample process on timesheet that triggers when a timesheet is submitted. 
2. Create a post condition on start step so that the process waits. 
   eg: process on timesheet object with postcondition thisTimesheet.status = approved or thisTimesheet.status = returned. 
3. Submit multiple timesheets so that in Processes - Initiated tab we see multiple processes running (i.e. waiting for condition). 
4. Select 5 running processes and click Cancel and confirm 

Expected : All 5 processes should be moved to ABORTED state.
 
Actual: 1 or 2 processes from the selected 5 are stuck in ABORTING state (This doesn't happen every time but easily reproducible over multiple attempts)

Environment

Release : 15.8.1, 15.9.1

Component : CA PPM APPLICATION ADMIN, STUDIO, XOG & PROCESSES.

Cause

This was due to defect DE60158 

Resolution

Reported as defect id: DE60158 and fixed in 15.9.2 

Workaround: Only a restart of Background service moves the stuck processes to ABORTED state.