Unable to add new device after previously deleting it in Spectrum with error SPC-OCC-11882
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Unable to add new device after previously deleting it in Spectrum with error SPC-OCC-11882

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Article ID: 213197

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When trying to add a new device after deleting the old model for that same device, the following error is thrown:

SPC-OCC-11882: A device model Unknown of type Unknown already exists but cannot be related to this view

When trying to destroy the device on the command line, 'No such model' is returned:

Environment

DX NetOps Spectrum all Releases
Component : Spectrum Discovery & Modeling

Cause

The Destroy threads in use never goes to zero, it's stuck on 15 (default maximum):

So the SpectroSERVER is stuck at trying to destroy the model. The most likely culprit is database corruption. 

Resolution

Run a database backup. Start a Spectrum Control Panel and click on the Save Database button. Then, click on the "Begin Backup Now" button. 

If you get a good backup of the database, try to shutdown the SpectroSERVER process by clicking on the Stop SpectroSERVER button. 

The SpectroSERVER may not shutdown if the destroy thread is hung. If it does not, kill the SpectroSERVER process. Then, click on the Restore Database button and restore to the database backup you just created. 

Once the restore is complete, start the SpectroSERVER by clicking on the Start SpectroSERVER button.

What should happen is the SpectroSERVER model activation process should see this model is flagged for deleting and delete it at startup.

If you are not able to get a good backup, then shutdown the SpectroSERVER and restore from a recent database save.