Clarity processes not completing in a reasonable time (DE57984 fixed in 15.9.2)
search cancel

Clarity processes not completing in a reasonable time (DE57984 fixed in 15.9.2)

book

Article ID: 213088

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

There are delays in process proceeding with further in steps after action items are approved. Processes progress sometimes delay for between 10 to 20 minutes.

Environment

Release : 15.8.1, 15.9.1

Component : CA PPM SAAS BUSINESS PROCESS MANAGEMENT

Cause

Pipeline threads get busy with condition evaluation of older processes which can cause slow performance.
End users noticed a big difference in how long processes take to complete. 

 

STEPS TO REPRODUCE: 

1. Execute a process so an End user carries out an Action Item. EG: approval an action and observe performance.

Expected Results: 

The process should complete in a reasonable time. 

Actual Results: 

Notice a big lag from when the action item within the step finishes and when the actual step completes can take up to 40 minutes before it gets recorded. 

Resolution

Logged as defect id: DE57984

Resolved in 15.9.2 New conditions will be evaluated first.