No Local Controller (LC) seen in CAMM Web UI in DX Netops CA Mediation Manager
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No Local Controller (LC) seen in CAMM Web UI in DX Netops CA Mediation Manager

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Article ID: 213044

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Updated On:

Products

DX NetOps CA Mediation Manager

Issue/Introduction

No Local Controller (LC) seen in  CAMM Web UI in DX Netops CA Mediation Manager 

When running /opt/CA/CAMM/tools/cammStatus from the Local Controller (LC), it shows the MC down but it is up, and I receive an error;

# ./cammStatus
MC 10.10.10.10 :      Stopped
Exception in thread "main" java.lang.IllegalArgumentException: port out of range:-1
        at java.net.InetSocketAddress.checkPort(InetSocketAddress.java:143)
        at java.net.InetSocketAddress.<init>(InetSocketAddress.java:224)
        at com.torokina.tim.communication.protocol.command.TimCommandNetworkClient.startClient(TimCommandNetworkClient.java:108)
        at com.ca.camm.bootstrap.cli.CammStatusCli.viewStatus(CammStatusCli.java:70)
        at com.ca.camm.bootstrap.cli.CammStatusMain.main(CammStatusMain.java:94)

The IP Address of MultiController MC is correct and the MC is up and running.

Environment

Release : 20.2

Component : CA Mediation Manager

Cause

There is a firewall or other network issue preventing communication from the LC to the MC.

Resolution

Correct the firewall/network issue preventing communication from the LC to the MC.

Additional Information

See the following for the default ports:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/mediation-manager/22-2/getting-started/default-ports-and-data-flow.html