BG going down frequently, restarting or stuck (threads issue)
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Article ID: 212885
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Updated On:
Products
Clarity PPM On PremiseClarity PPM SaaS
Issue/Introduction
Jobs are getting stuck frequently and when you cancel and reinitiate them the BG is stuck. You have to restart the BG again to process the jobs or the BG restarts by itself .
You notice evidence of BG running out of usable threads in the logs, such as Thread full message
Environment
Release : Any
Cause
Some of the possible causes include:
INFO logging on one or more classes that result in high number of messages being logged into the bg-ca.log
BPM_ERRORS table having high number of records
Increased load on BG
Resolution
Remove any INFO logging that is no longer needed and keep it to mininum, especially the Process Engine Persistence logging