After upgrade from Spectrum 10.4.0 to Spectrum 10.4.3 the OneClick server is not starting
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After upgrade from Spectrum 10.4.0 to Spectrum 10.4.3 the OneClick server is not starting

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Article ID: 212828

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Updated On:

Products

CA Spectrum

Issue/Introduction

We upgraded Spectrum from 10.4.0 to 10.4.3 and afterwards one of our OneClick servers was not starting.

When checking the tomcat log we can see the following errors:

 

14-Apr-2021 09:41:44.429 SEVERE [main] org.apache.tomcat.util.descriptor.web.WebXmlParser.parseWebXml Parse error in application web.xml file at [file:/ca/SPECTRUM/tomcat/webapps/spectrum/WEB-INF/web.xml]

                org.xml.sax.SAXParseException; systemId: file:/ca/SPECTRUM/tomcat/webapps/spectrum/WEB-INF/web.xml; lineNumber: 4339; columnNumber: 21; Error at line [4,339] column [21]: [The servlets named [ArchiverExpertServlet] and [ArchiverExpertServlet] are both mapped to the url-pattern [/repmgr/admin/tableStatus] which is not permitted]

..

Caused by: java.lang.IllegalArgumentException: The servlets named [ArchiverExpertServlet] and [ArchiverExpertServlet] are both mapped to the url-pattern [/repmgr/admin/tableStatus] which is not permitted

 

 

When we check the web.xml I see the ArchiverExpertServlet listed twice and the customer has not made any edits to this file

 

Line 3784

<servlet-mapping xmlns="">

    <servlet-name>ArchiverExpertServlet</servlet-name>

    <url-pattern>/repmgr/admin/tableStatus</url-pattern>

  </servlet-mapping>

 

 

 

Line 4336

servlet-mapping xmlns="">

    <servlet-name>ArchiverExpertServlet</servlet-name>

    <url-pattern>/repmgr/admin/tableStatus</url-pattern>

  </servlet-mapping>

 

When we commented out one of the duplicated servlets, the same error occurred for the next duplicate servlet.

Environment

Release : 21.2 / 20.2 / Spectrum 10.4.3

Component : Spectrum OneClick 

Cause

The web.xml file did not get recreated during the upgrade but was appended to, which caused the duplicate servlets to appear in the web.xml file.

Resolution

We replaced the bad web.xml file with a working one from another OneClick server that was also on the same version that did not have this problem.

If you do not have another web.xml file, please contact Support.