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"Error 401 User Not Registered" in Advanced Reporting clicking Home button
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Article ID: 212726
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Updated On:
Products
Clarity PPM On PremiseClarity PPM SaaS
Issue/Introduction
Users cannot navigate back to Advanced Reporting correctly from the 'Error 401 - User not registered' error page
STEPS TO REPRODUCE:
Log in to Clarity using an admin user
Navigate to Advanced Reporting
Create an Adhoc report and save it under a folder (it can be OOTB or customer)
Create a new user and add the below group and rights
Group: Basic group for user access (this is the default which comes with the product)
Rights:
Advanced Reporting – Navigate
Advanced Reporting - Report Create
Run the Create and update Jaspersoft user job
Log in to clarity with the newly created user and navigate to Advanced Reporting
Go to the folder where the Adhoc report is stored and click on the Adhoc view
User will get an error page which is fine with the below text:
You do not have permission to view this page.
Please contact your system administrator or log in as a user with permission
If you click on the highlighted section (Home icon) you get navigated to http://clarity/reportservice/exituser.html.
From this page, when you call from Jaspersoft, it triggers a logout, but in Clarity, you are not logged out (since it is embedded) but rather brought to a standard error page http://clarity/niku/nu#action:union.userInvalid with below error
Cause
This is a defect DE60481
Environment
Release : 15.8, 15.8.1,15.9,15.9.1, 15.9.2
Component : CLARITY JASPERSOFT
Resolution
Fixed in 15.9.3 as DE60481
Workaround: Provide user the Advance Reporting Create rights (Advanced Reporting - Ad Hoc Create)