Warning: "insufficient free space available after evicting expired cache entries" in TDM Portal Startup log
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Warning: "insufficient free space available after evicting expired cache entries" in TDM Portal Startup log

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Article ID: 212706

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

In the CA TDM Portal Startup.log we are seeing the below warnings. Can we make any changes to stop the warnings or we can ignore those warnings.

FINEST|15572/0|21-04-13 22:13:21|WARNING: Unable to add the resource at [/WEB-INF/classes/config/application.properties] to the cache for web application [/TestDataManager] because there was insufficient free space available after evicting expired cache entries - consider increasing the maximum size of the cache

Environment

All supported TDM releases.

Cause

These warnings are from the Tomcat server used by the TDM portal. This warning says Tomcat is unable to reach its target cache size. So, it is throwing such warning messages.

   You can ignore these warnings from startup logs. However, if the warning is filling up the startup.log, you may want to try adding allocating more memory to Tomcat.

Resolution

Before making modifications to the Tomcat configuration, please check how much available memory is on the TDM Portal server

To resolve the Warning:

  1. Edit 'CA Test Data Manager Portal\tomcat\conf\context.xml'
    by adding the following entry to the context.xml file 

    <!-- The default value is 10240 kbytes, even when not added to context.xml.
    So increase it high enough, until the problem disappears, for example, set it to
    a value 5 times as high: 51200. -->

    <Resources cacheMaxSize="51200" />

  2. Restart the CA Test Data Manager Portal service 

Additional Information

For more details about this Warning: