PMImport task fails with error: License expired
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PMImport task fails with error: License expired

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Article ID: 212552

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Updated On:

Products

Patch Management Solution

Issue/Introduction

The customer is trying to run PMimport task. However, it fails saying:

Overall result: License expired 

Looking at the NS logs, you may see entries like this:

c6d19f78-1434-49ac-bec8-d18255e99f57 license has expired.
-----------------------------------------------------------------------------------------------------
Date: 4/12/2021 8:55:27 AM, Tick Count: 149049953 (1.17:24:09.9530000), Size: 353 B
Process: w3wp (11128), Thread ID: 31, Module: Altiris.PatchManagementCore.dll
Priority: 4, Source: Altiris.PatchManagementCore.Licensing.LicensingHelper.CheckLicenseForComputer

where 'c6d19f78-1434-49ac-bec8-d18255e99f57' GUID refers to Altiris Patch Management Solution.

Environment

ITMS 8.5, 8.6

 

Cause

Expired licenses.

Make sure you actually look at the licensing page instead of the primary SIM page. For example:

1. In this scenario, Patch Management Solution shows that there are enough licenses:

2. But, if you go SIM>Add/Update licenses page, it shows that actually the licenses are expired:

Resolution

Please obtain a new set of licenses with a current expiration date.

Please refer to the following KBs if you need more details about how licensing works:

KB 178715 "Altiris Licensing - Technical FAQ"

KB 180699 "How does managed client consume a Patch Management Solution license for 7.5, 7.6, 8.0, 8.1.x, and 8.5.x?"

Attachments