cspmclient binary usage error: error while loading shared libraries: libidn.so.11
search cancel

cspmclient binary usage error: error while loading shared libraries: libidn.so.11

book

Article ID: 212479

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

After upgrading to CAPAM A2A Client 4.12.3.8 in Linux machine, unable to use the existing script with the below error.

 $CSPM_CLIENT_HOME/cspmclient/bin/cspmclient <script name> true
./cspmclient: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory

Where as the old 4.5.300 Cloakware client works with the same file.

$CSPM_CLIENT_HOME/cspmclient/bin/cspmclient <alias> true

400 <alias> XXXXXXX

Like the below example

# /opt/cloakware/cspmclient/bin/cspmclient <alias>

/opt/cloakware/cspmclient/bin/cspmclient: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory

Cause

The A2A client is searching for the "libidn.so.11" 32-bit shared object file.

Based on the traditional Linux deployments this file is in the /lib directory.

Nonetheless, we most Operating System going to 64-bit, you should be using the cspmclient64 client instead.  

Resolution

Certain deployments of UNIXLinux do not install the "libidn.so.11" 64 bit shared object file.

Since this is a missing OS shard object, this needs to be deployed by the customer by downloading it from the OS vendor.

Additional Information

As per the product documentation, we no longer support 32bit OS deployments.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-access-manager/4-2/protect-privileged-account-credentials/manage-credentials-between-applications-a2a/install-and-activate-an-a2a-client-on-a-request-server.html