Performance Test Ends Early with "exported.jetlag.ldjson has not been written to in the appropriate time frame" WARNING in the bzt.log
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Performance Test Ends Early with "exported.jetlag.ldjson has not been written to in the appropriate time frame" WARNING in the bzt.log

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Article ID: 212444

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Updated On:

Products

BlazeMeter

Issue/Introduction

A performance test ends abruptly after 18 minutes even though it is configured to run for 2 hours and 15 minutes.  Warnings similar to the following appear in the bzt.log for the test:

[2021-04-09 17:58:33,274 WARNING Engine.ldjson-results] exported.jetlag.ldjson has not been written to in the appropriate time frame - moving to end the test gracefully
[2021-04-09 17:58:33,315 WARNING Engine] Please wait for graceful shutdown...

Environment

Release : SAAS

Component : BLAZEMETER PERFORMANCE TESTING

Cause

BlazeMeter will wait for 5 minutes to receive data before initiating a graceful shutdown.  If no data is received after waiting for 5 minutes then it begins the shutdown process.  Unfortunately there is no way to adjust this setting in order to increase the timeout window at this time.  It's a hard limit that is set in the backend of the application.

Resolution

Debug the JMX script by testing it locally as specified in the Step 2: Test Locally with JMeter section of the Calibrating a JMeter Test before running the JMX script in BlazeMeter to make sure that the script will work as expected and responses are received for requests made.