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Continuously getting FATAL errors in JBoss log affecting performance

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Article ID: 212431

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Updated On:

Products

CA Identity Suite

Issue/Introduction

After migrated Identify Manager to version 14.4, getting the following error in the JBoss log:

FATAL [org.apache.myfaces.shared_impl.webapp.webxml.WebXmlParser] (ServerService Thread Pool -- 103) Unable to parse web.xml: java.net.ConnectException: Connection timed out: connect

This does not prevent any function in Identity Manager from executing successfully, but it has made Identity Manager painfully slow.

 

 

Cause

This is due to dtd file is not able to access online and cannot be validated

Environment

Release : 14.4

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Resolution

For 14.4 GA Standalone Installation Type:

1) Download web-app_2-3.dtd from  http://java.sun.com/dtd/web-app_2_3.dtd

2) Modify web.xml file under user_console.war/WEB-INF

3) Change the following line 

From

<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">

To 

<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "/absolute path of the dtd location/web-app_2_3.dtd">

To 14.4 GA Virtual Appliance Installation Type:

The procedure above is not possible in Virtual Appliance because have no permissions to update manually the web.xml.


Additional Information

For Virtual Appliance 14.4GA :

1) visit this another Article that provides a workaround using one external IIS 

https://knowledge.broadcom.com/external/article?articleId=213792

Also

2) Check if new CP was published with a HF about this problem if not,  if have new fix you can skip use above workaround. or

3) Open a Support case