ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Jaspersoft reports fail with TCP/IP connection failure

book

Article ID: 212421

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

While running reports from Advanced Reporting on a new Clarity installation, the below error is received:

The server has encountered an error. Please excuse the inconvenience. 

Error Message

An error occurred while creating the connection. Try again. 

Clarity has been freshly installed with Jaspersoft on the latest versions, one server per application.

Excerpt from jasperserver.log:

2021-03-27 23:41:32,984 ERROR ErrorLogger,quartzScheduler_QuartzSchedulerThread:2361 [] - An error occurred while scanning for the next triggers to fire.
org.quartz.JobPersistenceException: Failed to obtain DB connection from data source 'springNonTxDataSource.quartzScheduler': com.microsoft.sqlserver.jdbc.SQLServerException:The TCP/IP connection to the host cw-001526, port 1433 has failed. Error: "Connection refused. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port.Make sure that TCP connections to the port are not blocked by a firewall.". [See nested exception: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host cw-001526, port 1433 has failed. Error: "Connection refused. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".]

Investigation performed:

  1. Verified the reporting service is up and running and Advanced Reporting navigation work
  2. Deleted all profile attributes in Jaspersoft for the user "jasperadmin" and ran the following Jaspersoft admin commands successfully:
    admin update jasperParameters
    admin jaspersoft syncPPMContext -userName superuser -password superuser
  3. Re-generated the keystore as per install documentation
  4. Restored Jaspesoft (JS) domains via the below command 
    admin content-jaspersoft csk restoreDomains -userName superuser -password superuser
  5. Ran Load Data Warehouse jobs successfully

Screenshot of error below:

Cause

Jaspersoft server is unable to communicate to DB servers.

Environment

Clarity Release 15.9.1

Jaspersoft 7.8

Resolution

Whitelist all connections between the Jaspersoft server and the SQL DB

Additional Information

See also: Jaspersoft / reports known issues with Clarity

Attachments