Unable to access OneClick WebApp when using F5 VIP
search cancel

Unable to access OneClick WebApp when using F5 VIP

book

Article ID: 212236

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction


After setting up our Spectrum OneClick Servers behind an F5 VIP the Webapp no longer launches

The VIP  is setup as follows: 

  • http://spectrum.domain.net 
    • ==> directs us to http://<oneclickserver>:8080/spectrum

  • LDAP Authentication at this stage works just fine. 

  • Select OneClick WebApp 
    • ==>  Get a blank page 

   

 

Environment

Release : 10.4.x (NetOps 20.2.x)

Component : Spectrum Core / SpectroSERVER

Cause


The OneClick tomcat redirects Webapp traffic to the Webtomcat port (Default: 9443 TCP). The Webtomcat port (9443) also needs to be
    opened through the F5 load balancer.


The http://host.domain.net:8443/spectrum/webapp  will redirect to http://host.domain.net:9443/spectrum/oneclickwebapp so both
   ports will need to be opened through the F5.


Resolution


Both the OneClick Tomcat port and Webtomcat port need to be open though the F5 loadbalancer.

 

The Webtomcat which runs webswing and launches the java console locally uses port
   9443 by default. The OneClick webpage when launching the Webapp will redirect to port 9443 which
   means that both the OneClick tomcat and the Webtomcat ports need to be routed through the F5

Additional Information

 

The Webapp can be accessed directly to test connectivity and see if the F5 is also permitting port 9443
  

  • ==> http://OneClickServer.acme.net:9443/spectrum/oneclickwebapp

 

SSL
  If OneClick tomcat and Webtomcat are configured to use SSL, make sure to follow the steps to update the WebSwing configuration