Detection server migration tool error during upgrade
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Detection server migration tool error during upgrade

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Article ID: 212190

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Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

You are upgrading detection servers to 15.8 using the migration tool

You have run the tool from the command line with local administrator rights on the server, however you receive a migration error and the lines below are in the migration utility.log

Environment

Release : 15.8

Component : Migration Tool

Cause

File: MigrationUtility.log
Class: com.symantec.dlp.migrationcommon.MigrationActionsExecutor
Method: executeMigrationActions
Level: SEVERE
Message:  Failed to execute migration actions. Please refer to the log file for details
com.symantec.dlp.migrationcommon.MigrationException: Failed to run migration action "SetTargetIndexersJREConfigFiles"
 at com.symantec.dlp.migrationcommon.MigrationActionsExecutor.runMigrationAction(MigrationActionsExecutor.java:72)
 at com.symantec.dlp.migrationcommon.MigrationActionsExecutor.executeMigrationActions(MigrationActionsExecutor.java:118)
 at com.symantec.dlp.migrationcommon.MigrationUtility.runMigrationUtility(MigrationUtility.java:168)
 at com.symantec.dlp.migrationcommon.MigrationUtility.runMigrationUtility(MigrationUtility.java:106)
 at com.symantec.dlp.migrationcommon.MigrationUtility.runMigrationUtility(MigrationUtility.java:112)
 at com.symantec.dlp.detectionservermigrationutility.DetectionServerMigrationUtility.runMigration(DetectionServerMigrationUtility.java:38)
Caused by: com.symantec.dlp.migrationcommon.MigrationException: Error updating JRE setting.
 at com.symantec.dlp.serverjremigrationutility.actions.UpdateJREServiceConfigFilesMigrationAction.runAction(UpdateJREServiceConfigFilesMigrationAction.java:202)
 at com.symantec.dlp.migrationcommon.MigrationActionsExecutor.runMigrationAction(MigrationActionsExecutor.java:65)
 ... 5 more
Caused by: com.symantec.dlp.migrationcommon.jni.JNIException: Error calling RegOpenKeyExA: Access is denied.

Resolution

In this instance the migration was completed successfully as below.

  1. Stop the detection service manually on the affected server
  2. Re-run the migration tool as an Administrator
  3. Start the service