ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Upgrade to 15.9.1 fails with "SQL error code: 1105", error: "Could not allocate space for object..."

book

Article ID: 212103

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

As per the install.log, the error thrown is:
SQL error code: 1105
Error message: [CA Clarity][SQLServer JDBC Driver][SQLServer]Could not allocate space for object 'niku.CMN_MENU_ITEMS'.'CMN_MENU_ITEMS_N2' in database 'cappm' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

Cause

This is a database issue as space has run out on MSSQL tempdb for internal objects, temp tables, etc.

Environment

Release : 15.9.1

Component : CLARITY UPGRADES

Resolution

Contact your DBA and ask them to address the issue.

Here is a Microsoft KB which explains a few strategies your DBA can choose: Troubleshooting Insufficient Disk Space in tempdb