DDSDCLM SDC VERIFY DDPUNA0001 USER NOT AUTHORIZED  
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DDSDCLM SDC VERIFY DDPUNA0001 USER NOT AUTHORIZED  

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Article ID: 212068

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Updated On:

Products

Datacom Datacom/DB Datacom/AD

Issue/Introduction

Datacom DDSDCLM SDC VERIFY fails with error:

DDSDCG005I       BEGIN OCCURRENCE VERIFICATION FOR SYNONYM                                                           
   **** ERROR ****  RETURN CODE = DDPUNA0001  USER NOT AUTHORIZED

Environment

Release : 15.1

Component : DATACOM DATADICTIONARY

Cause

The error can be caused by the user missing the $DD-ADM Security Administrator authorization in their profile. 

It the user already has the $DD-ADM authorization it means a table is missing from the profile.

Resolution

Run DDUTILTY using the following input to report all users with the profile $DD-ADM and also all tables that are accessible by that profile.

//SYSIN  DD *
-USR DATACOM-INSTALL,NEWUSER
-DEF PATH,STANDARD
-END
-RPT RELAT,AUTHORIZATION,$DD-ADM(PROD,PRIV)
-END
/*

Check the report to see if the user is listed. If not listed, the user does not have Security Administrator authorization.

If the user missing Security Administrator authorization

Perform the following steps to add the  Security Administrator authorization to the user:

  1. Run DDUPDATE with the following input:
    //SYSIN  DD *
    -USR DATACOM-INSTALL,NEWUSER
    -UPD PERSON,userid(PROD,DD)
    1010 ADD $DD-ADM
    -END
    /*
  2. Run DDCFBLD to perform an HSD RESET. Use this input:
    //SYSIN  DD *
    -USR DATACOM-INSTALL,NEWUSER
    -HSD RESET
    /*
  3. Run the DDSDCLM SDC VERIFY again, it should now run without any authorization errors.

If the user already has Security Administrator authorization

Look for the table in the DDSDCG005I message in the report.

In the example above it was SYNONYM but in some cases also the VIEW table is the problem.

It should look like this, but there may be more versions of the tables:

       SYNONYM                                                             (0001)          OBJ       YES       NO
                                                                                                                
                                               YYYYYYYYYYYYYYYYYYYN
     SYNONYM                                                             (0018)PROD      OBJ       YES       NO
                                                                            DD ENTITY FILE
                                               YNYYNNNNNNNNNYYYNYNN
     VIEW                                                                (0001)          OBJ       NO        NO                        
                                                                                               
                                           YNYYNNNNNNNNNYYYNYNN                                                                      
   VIEW                                                                (0018)PROD      OBJ       YES       NO                        
                                                                        DD ENTITY FILE    
                                           YNYYNNNNNNNNNYYYNYNN                                                                      

If the entries are not there or the PROD version of the tables are missing, perform the following steps:

  1. Run DDUPDATE with the following input:
    //SYSIN  DD *
    -USR DATACOM-INSTALL,NEWUSER
    -UPD PROFILE,$DD-ADM
    1012 ADD VIEW(ALL)
    1013 Y N Y Y N N N N N N N N N Y Y Y N Y N N
    -END
    -UPD PROFILE,$DD-ADM
    1012 ADD SYNONYM(ALL)
    1013 Y N Y Y N N N N N N N N N Y Y Y N Y N N
    -END
    /*
  2. Run DDCFBLD to perform an HSD RESET. Use this input:
    //SYSIN  DD *
    -USR DATACOM-INSTALL,NEWUSER
    -HSD RESET
    /*
  3. Run the DDSDCLM SDC VERIFY again, it should now run without any authorization errors.

Additional Information