How to disable xFlow/Service Point on non-secure port 9002 so end users will always use secure port

book

Article ID: 211686

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

After SDM admin follows https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/troubleshooting1/troubleshooting-xflow-interface/enable-secure-socket-layer-for-xflow-interface.html steps to configure xFlow/Service Point to use secure port 9444, the expectation is end users will use https://xFlow-server:9444. However, as the original port 9002 is still open end users may continue to use none secure port http://xFlow-server:9002 and doing this will cause some security issue or other issues. This tech doc discusses a simple way to disable the non-secure port 9002. 

Cause

Port 9002 is still open and be used. the documented steps do not touch the existing non-secure port 9002.

Environment

Release : 17.3, 17.2, 17.1

Component : USRD

Resolution

Follow these steps

--make a backup copy of ServerConfig.xml file in xFlow-directory\APP

--edit ServerConfig.xml file in xFlow-directory\APP : remove this line

<IncidentService FolderName="incidentmicroservice-17.0.479" BatchFile="incidentmicroservice.bat" Port="9002"/>

--recycle xFlow service